Knowledgebase : Technical, Configuration and Devices > Printing issues

Having the correct drivers installed for your printers, is a very important part of the configuration to ensure that the speed of the application and print job completion, is optimal.

There are several key points:

  1. Install the printer driver locally (on the computer you are using).  Don't use a 'shared' printer driver.  
  2. If staff login at different computers, ensure the Name of the printer driver is exactly the same on each workstation e.g. 'Dymo Labelwriter 550'
  3. If you are connecting to a Remote Desktop session or Incisive inCLOUD, only use label printers that have an ethernet (network) port (e.g. Brother QL-700 NWB), or if there is only a USB cable for the printer (e.g. Dymo Labelwriter), have a separate label printer for each workstation.
  4. Use a cable to connect to the printer, not Wifi
  5. Choose the correct paper size in the Printer Preferences.  Especially for label printers.
  6. In Windows > Printers & Scanners, disable the option to 'Allow Windows to manage my default printer'.
  7. In the Incisive application, make sure you have the correct printers selected in Setup > Workstation > Configuration.

After installing your printer driver(s) please ensure that you can do a test print from Windows to the device.

To do a test print from Windows

From (Windows) Settings > Printers & Scanners, select the printer.

Windows Printers & Scanners



To do a test print from an Apple Mac

Use a browser and put in the URL of   localhost:631/printers   which should load the CUPS interface

Select the printer then go to Maintenance > Print Test page.

If a test page fails to print, please contact your hardware technician.

If a test page has printed, then proceed with configuring the printer in the Incisive application.

Incisive recommend that if you are hosted in the inCLOUD.clinic system or you have your own Terminal Server (Remote Desktop) environment, you should be using TSPrint or TSScan to get an optimal experience.

You will need to install the TSPrint Client and TSScan Client applications on the local workstation/laptops so that they perform correctly.

The installation process is very simple and no additional licensing is required.

Instructions to install and configure TSPrint for SPM & PHM applications

The TSPrint guide from Terminal Works is available:

Windows -  https://www.terminalworks.com/remote-desktop-printing/downloads/documentation/TSPrintGuide.pdf

Machttps://www.cloudwalks.com/uploads/2/6/6/5/26654030/printing_guide_for_mac.pdf (this is a bit old)

Configure TSScan for Windows

The TSScan install file is downloaded from https://www.terminalworks.com/downloads/tsscan/TSScan_client.exe 

After installing, go to TerminalWorks > TSScan Client Settings in the Windows Start menu and select your default scanner


Configure TSPrint for a Mac

The TSPrint install file is downloaded from this site:

https://www.terminalworks.com/downloads/tsprint/macosx/TSPrintClient.zip 

After installing the app, check the inCLOUD → Mac printer mappings are correct.  If not, delete then choose the correct printer when printing the next time.

Delete any that are incorrect or obsolete

Print from SPM and choose the correct printer when the prompt appears.



Configure TSScan for Mac

Scanning from an Apple Mac Book

When printing labels from SPM/PHM to a Brother QL-700 label printer, the print job may be created correctly but the labels don't print and a message appears "The roll of labels or tape inside the machine does not match the one selected in the application".  

Use the following URL to trouble-shoot the problem

https://support.brother.ca/app/answers/detail/a_id/134639/~/the-roll-of-labels-or-tape-inside-the-machine-does-not-match-the-one-selected

Symptom:
Print jobs are going to the wrong printer.
The printer is correctly configured in Setup > Printers and the correct one is selected in Setup > Workstation > Configuration.
A Test Priint at Windows level works fine.

Cause:
The printer has insufficient permissions.
The Incisive application needs to be able to programmatically change the 'Default' printer and is unable to so goes to the first one on the list of printers that it can.

Remedy:
In the Properties of the printer driver change the Security settings for the User to be allowed to 'Manage the Printer'

Troubleshooting:
There are a couple of (Incisive) programs written to assist with troubleshooting printer problems.

PrinterTest.exe (\\nas\exefiles\alpha)
This lists and allows selection of printers using various methods that spm_fakeprinter does (but not using the fake printer).

ViewPrintersNet.exe (\\nas\exefiles\utilities)
Will test the permissions and lists the printers visible from .net.

Logging for spm_fakeprinter.dll
To enable this, you need to set a flag in the workstation .INI file:
[IncisiveSoftware]
PrinterSelectionLogging=0/1/2                         (‘0=off, 1=simple logging, 2=verbose logging)
The data will be logged in the file “c:\spmwin\PrinterSelection.log”.  See the attached sample file.



 

The data will be logged in the file “c:\spmwin\PrinterSelection.log”.  See the attached sample file.

The option to select a printer each and every time you print can be turned on for the Workstation (or Network login if Citrix = True) using Winflex.

Set as follows:

WrkStation.wrk_DialogWhenPrinting = 1

This will only be performed by Incisive staff.

 

If you want to include a second surgeon or other clinicians on a worksheet label, you can either use the existing merge fields or create a pop-up input option that would allow you to manually type in the surgeon's name.

There are Merge fields for Anaesthetist and Assistant
XcW6c1YAAAAAElFTkSuQmCC

The Primary surgeon will always be the Referring Dr., so you could use that merge field
Mfw2F861BsAAAAABJRU5ErkJggg==

These are the merge fields you can add to the label:
iUuknDhE8egAAAABJRU5ErkJggg==

Which prints as:
weH+MIz1VVtYwAAAABJRU5ErkJggg==

Alternatively, you could construct a completely new label type and include a 'prompt' field that allows you to manually enter the name when the label is used. 

New labels are created in Setup > Labels.  Add a new field with  < >  (there is a space between the angle brackets)
dH9vtFdY6J4AAAAASUVORK5CYII=

Select the new label type when printing the label.  The following Input field will appear.  Manually enter in the surgeon's name.
UCQAAlEuiCwAAQKVodAEAAKgUjS4AAACVotEFAACgUv4f3w9SbxkzDpEAAAAASUVORK5CYII=

The label will print as follows:
ND5UcxYqqaSSUlIlC5VUUkkpqZKFSiqppJT+D6I+qNpcErQrAAAAAElFTkSuQmCC

The barcode on the prescription is using the Code128 barcode type which is available from the Code128nWin.ttf font.  The font is provided with the Incisive application.

  1. Check the font is installed in Control Panel > Fonts

  2. To install the font:
    1. Login as an Administrator
    2. Right-click on the code128bwin.ttf file
    3. Choose 'Show more options'
    4. Choose 'Install for All Users'
  3. Complete the installation
  4. Logout or restart to load the font file.

You can check that it has been correctly installed by looking for the Code128bwin key in Registry Editor

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts

SPM/PHM will list the printers that you have available to your Windows profile.

If a printer is not appearing in the list or has previously been used with SPM/PHM but a message is saying that it is no longer available, try to following steps first:

  • Ensure the printer is turned on or that the workstation that the printer is plugged into is turned on.
  • Check there is paper in the trays as the printer may of taken itself 'off-line'.
  • At the Windows level, select the printer and do a 'Test Print'.  If this isn't successful, contact your hardware technician, as the Incisive application will not be able to print if you can't do a test print.
  • Log out and restart your workstation to make sure that your Windows login is successfully finding and connecting to the printers installed for your profile.

Problem: 

Can't find a printer in Setup > Printers. 

Even though it is showing on the local workstation/laptop in Windows > Control Panel > Devices & Printers

Conditions:

  • Running in Terminal Server or Remote Desktop environment.
  • There is a list of more than twenty (20) printers

The default setting for Microsoft Terminal Services or Remote Desktop is to only display the first twenty printers.

Resolution:

  1. Edit the Registry to enable more printers to display
    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc727415(v=ws.10)
  2. Install the exact same printer driver (and name) on the terminal server