Knowledgebase : Technical, Configuration and Devices > Printing issues

When printing labels from SPM/PHM to a Brother QL-700 label printer, the print job may be created correctly but the labels don't print and a message appears "The roll of labels or tape inside the machine does not match the one selected in the application".  

Use the following URL to trouble-shoot the problem

https://support.brother.ca/app/answers/detail/a_id/134639/~/the-roll-of-labels-or-tape-inside-the-machine-does-not-match-the-one-selected

Problem: 

Can't find a printer in Setup > Printers. 

Even though it is showing on the local workstation/laptop in Windows > Control Panel > Devices & Printers

Conditions:

  • Running in Terminal Server or Remote Desktop environment.
  • There is a list of more than twenty (20) printers

The default setting for Microsoft Terminal Services or Remote Desktop is to only display the first twenty printers.

Resolution:

  1. Edit the Registry to enable more printers to display
    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc727415(v=ws.10)
  2. Install the exact same printer driver (and name) on the terminal server

Incisive recommend that if you are hosted in the inCLOUD.clinic system or you have your own Terminal Server (Remote Desktop) environment, you should be using TSPrint or TSScan to get an optimal experience.

You will need to install the TSPrint Client and TSScan Client applications on the local workstation/laptops so that they perform correctly.

The installation process is very simple and no additional licensing is required.

Instructions to install and configure TSPrint for SPM & PHM applications

The TSPrint guide is available:

Windows -  https://www.terminalworks.com/remote-desktop-printing/downloads/documentation/TSPrintGuide.pdf

Machttps://www.cloudwalks.com/uploads/2/6/6/5/26654030/printing_guide_for_mac.pdf (this is a bit old)

Symptom:
Print jobs are going to the wrong printer.
The printer is correctly configured in Setup > Printers and the correct one is selected in Setup > Workstation > Configuration.
A Test Priint at Windows level works fine.

Cause:
The printer has insufficient permissions.
The Incisive application needs to be able to programmatically change the 'Default' printer and is unable to so goes to the first one on the list of printers that it can.

Remedy:
In the Properties of the printer driver change the Security settings for the User to be allowed to 'Manage the Printer'

Troubleshooting:
There are a couple of (Incisive) programs written to assist with troubleshooting printer problems.

PrinterTest.exe (\\nas\exefiles\alpha)
This lists and allows selection of printers using various methods that spm_fakeprinter does (but not using the fake printer).

ViewPrintersNet.exe (\\nas\exefiles\utilities)
Will test the permissions and lists the printers visible from .net.

Logging for spm_fakeprinter.dll
To enable this, you need to set a flag in the workstation .INI file:
[IncisiveSoftware]
PrinterSelectionLogging=0/1/2                         (‘0=off, 1=simple logging, 2=verbose logging)
The data will be logged in the file “c:\spmwin\PrinterSelection.log”.  See the attached sample file.



 

The data will be logged in the file “c:\spmwin\PrinterSelection.log”.  See the attached sample file.

After installing your printer driver(s) please ensure that you can do a test print from Windows to the device.

To do a test print from Windows

From (Windows) Settings - Printers & Scanners, select the printer.

Windows Printers & Scanners

  • Select Manage
  • Select Print a test page
  • A Windows test page should print.

If a test page fails to print, please contact your hardware technician.

If a test page has printed, then proceed with configuring the printer in the Incisive application.

SPM/PHM will list the printers that you have available to your Windows profile.

If a printer is not appearing in the list or has previously been used with SPM/PHM but a message is saying that it is no longer available, try to following steps first:

  • Ensure the printer is turned on or that the workstation that the printer is plugged into is turned on.
  • Check there is paper in the trays as the printer may of taken itself 'off-line'.
  • At the Windows level, select the printer and do a 'Test Print'.  If this isn't successful, contact your hardware technician, as the Incisive application will not be able to print if you can't do a test print.
  • Log out and restart your workstation to make sure that your Windows login is successfully finding and connecting to the printers installed for your profile.

The option to select a printer each and every time you print can be turned on for the Workstation (or Network login if Citrix = True) using Winflex.

Set as follows:

WrkStation.wrk_DialogWhenPrinting = 1

This will only be performed by Incisive staff.